Marking G-code

2506tomi shared this question 2 months ago
Answered

Hi,

I have dxf with two layers type with different colors. How Fastcam identified which is for marking and which for cutting?

Files: test.png

Comments (8)

photo
1

Hi 2506tomi

You can first setup layer mapping in FastCAM

http://response.fastcam.com/knowledge-base/article/mapping-new-dxf-layer-to-cuttingmarking-process-in-fastcam

Once you've done this,

Then also make sure to have selected both marking and cutting/plasma/oxy processes in FastPATH.

ae2e140fa3736cdc93581228ea93b3d3

Then on code output it will know to treat the mapped layer to the corresponding process.


-regards

photo
1

Ok. Thanks.


I got a G-code from the manufacturer for the Plasma Cutting and Marking Testing (TEST MARK ORIG.txt) in the attachment. This one works normally on a CNC machine.


I also created my test g-code but it doesn't work properly on the machine (ABC TEST.TXT) in the attachment.

I think the Marking command in the G-code is not correct but i don't know how to change it.


Thanks and regards.

Tomi

photo
1

I think it should be a command for MARKER ON M63 and MARKER OFF M64.


If so, how to change it?

photo
1

To change the M-codes the POST PROCESSOR needs to be modified. Or choosing a more appropriate POST during install.

you can try send in a service email,

http://response.fastcam.com/knowledge-base/article/ho-do-i-send-a-service-email

From the FastCAM service email we can check your installed POST and advise further.

Let us know the Brand and Model of your cutting machine and CNC controller as well.

regards,

Jackson

photo
1

It is a CNC plasma cutter with a rotary axis and a mechanical marking head dimensions 4000x2000 mm. The controller is the STARFIRE SF-2310SG.

photo
1

The controller to choose during install, if it did ask, is "START" for STARFIRE.

How'd you go with attempting the service email feature?

photo
1

Even if I select "Start", the marking on the machine does not work when. As shown in the enclosed G-code is the command to activate the marking head M63.

How to change the M-codes in the POST PROCESSOR ? Or what do you suggest?


/0d606f8599dca971d4b129c9243d3fc3

photo
1

Follow the service email guide and send a service email through to us, it will package automatically your START POST in the service email.

We will make modifications to it and send it back to you configured to: "MARKER ON M63 and MARKER OFF M64"

photo