Need update link.

nurken shared this question 3 months ago
Answered

Hi, licence #53479. FastCam Standard 7.0.10. Need update link and russian language.

Comments (1)

photo
1

Hi,

Sadly that version of FastCAM is too old for me to provide an update. The only option I have is for you to purchase the latest FastCAM 8, which you can learn more about here:

http://response.fastcam.com/announcement/fastcam-8-released

If you have any other questions however, please let me know!

Cheers,

Alexander Fagan