Problem FastLOCK

Andrej shared this question 4 years ago
Answered

I can't start FastCam, When I try reset table on screen "Operation not permitted by FastLock. Please check software version with FMS FastCAM". Please help me

Comments (15)

photo
1

Hi Andrej,


Thank you for using the community.


From the image you attached i can see you are using windows 8, is that 32bit or 64bit OS?


What colour is your fastcam licence dongle?


Do you have your fastcam licence number?


Thanks

FastCAM Support

photo
1

Hi Andrej,


Thank you for your email.


The Blue licence dongle you have is not supported on a widows 8 32bit OS.


To have the latest fastcam that is compatible with both 32bit and 64bit windows 8 please vist our web store found at http://www.fastcam.com

photo
1

Hello, when you open the program I get the following message: FASTLOCK not allow the operation, check the versions of the FMS program FastCAM.

My operating system windows xp 32 and windows 7 64-bit

The key is gray with white letters and number that comes is 101930327, and the software is FASTCAM 5.10 and the upgrade is FASTCAM 2000, I hope to help with this problem as I make my pieces urges cutting.

regards

photo
1

Jesus Hernandez Guzman wrote:

Hello, when you open the program I get the following message: FASTLOCK not allow the operation, check the versions of the FMS program FastCAM.

My operating system windows xp 32 and windows 7 64-bit

The key is gray with white letters and number that comes is 101930327, and the software is FASTCAM 5.10 and the upgrade is FASTCAM 2000, I hope to help with this problem as I make my pieces urges cutting.

regards

Hi Jesus,


Sorry to hear you are having issues, are you not able to use FastCAM on both your XP machine and your 64 bit windows machine? And is the dongle flashing it's green light when you plug it in in both machines, before you try to load up FastCAM?


Cheers,


Alex

photo
1

Goodnight


Indeed install on two machines with different operating systems, and green usb light flashes but I get that error I can do.


regards

photo
1

Jesus Hernandez Guzman wrote:

Goodnight


Indeed install on two machines with different operating systems, and green usb light flashes but I get that error I can do.


regards

Ok, is this a recent problem? Have you been using FastCAM successfully up until now?

photo
1

Goodnight


I had the software installed on a machine with windows xp sp3 32 bit funcianaba perfectly, but unfortunately the hard disk damage and now I try to reinstall it installed as indicated in the manual version and then upgrade 510 2000 and not me lets open it I get the error that comment.


regards

photo
1

Hi Jesus,


I would recommend you add the attached file 'Unikey.dll' to your %SYSTEM% folder. Then try again. (making sure the dongle is in and the light is solid)


If that doesn't work, walk through the attached guide:

USBdongle_driver_instructions.pdf


And if that still doesn't work, Run the FastUnikeyTest, and make sure it is coming back with your dongle number and Dongle number found! If it is coming back with found, but you are still unable to run FastCAM, then let me know.


For your information %SYSTEM% is in the following locations -

32 bit machines: C:\Windows\system32\

64 bit machines: C:\Windows\syswow64\


Cheers,


Alex

photo
1

Copy and paste the file 'Unikey.dll' and left the same message USBdongle_driver install the program and once again they the serial number of the key, in all cases the key had the LED on and blinking but when you open the software get the same message.

regards

photo
1

Jesus Hernandez Guzman wrote:

in all cases the key had the LED on and blinking
If it is Blinking, the dongle could well have died. It should be a solid light.


Please download this:

http://www.fastcamusa.com/Trevor/FastCAMReadlockInstall.zip


Install and run it, with the dongle plugged in. This will come back with a screen of what is on the dongle for us to check. Can you take a screenshot of this and please either reply with the screenshot attached here, or send the screenshot to me at alex.fagan@fastcam.com.au


Cheers,


Alex

photo
1

goodnight


Attached I send you the screen image that came to me.


regards

photo
1

Jesus Hernandez Guzman wrote:

goodnight


Attached I send you the screen image that came to me.


regards

Ok so that's a good thing, it means we won't have to replace your dongle, and likely what has happened is something to do with the software.


You said you installed FastCAM 5.10 and THEN upgraded to Fastcam 2000? Are you sure it was supposed to be in that order?


Also can you send me a screenshot of your fastcam.exe properties?

Head to C:\Program FIles\FastCAM\

Right click fastcam.exe

select properties

Goto the details tab

Send me a screenshot of this tab, it should look like the attached screenshot

photo
1

Goodnight


That's first and install the version after the upgrade 510 2000 if I install first since the 2000 upgrade can not install the 510 version, and I send you attached three screens, the first folder with all the files, the second with the properties of the version 510 and then the 2000 upgrade.


regards

photo
1

Goodnight


Shipping for more images.


regards

photo
1

Jesus Hernandez Guzman wrote:

Goodnight


Shipping for more images.


regards

Hi again Jesus,


I have had another look at your versions, and found that they are all below the minimum useable with the dongle you have there.


If you had this running before, with the same dongle, then you need to find the install material you used on the old machine, to get it up to 5.10.279 version of FastCAM (which is the minimum version allowable for that dongle)


If you cannot find this, you are going to have to look at purchasing the latest version of fastcam.


Cheers,


Alex